Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Project dies in Release configuration



Permlink Replies: 4 - Last Post: Sep 30, 2015 11:44 PM Last Post By: Markus Humm
Steven Wiberg

Posts: 28
Registered: 3/6/12
Project dies in Release configuration
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 30, 2015 9:22 AM
So I just upgraded from XE8 to 10 Seattle and went to build my android project.

It was working fine in XE8 but now that I have upgraded my project will not build in Release Configuration for an app store submission for android; however, when I build my project in Debug Configuration it works fine, I have gone through all the project options I can see and played around with them with no success.

I have looked in my project and do not have any IFDEF statements for debug or release.

As well I have deleted the Android folder that gets created when the project is run with no success, I have renamed my custom AndroidManifest.template.xml that I was using which forced delphi to create a new copy of the manifest and that did nothing.

I am out of ideas as to why my project would work in Debug but not Release.

Any help would be greatly appreciated.
Markus Humm

Posts: 5,113
Registered: 11/9/03
Re: Project dies in Release configuration
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 30, 2015 9:43 AM   in response to: Steven Wiberg in response to: Steven Wiberg
Am 30.09.2015 um 18:22 schrieb Steven Wiberg:
So I just upgraded from XE8 to 10 Seattle and went to build my android project.

It was working fine in XE8 but now that I have upgraded my project will not build in Release Configuration for an app store submission for android; however, when I build my project in Debug Configuration it works fine, I have gone through all the project options I can see and played around with them with no success.

I have looked in my project and do not have any IFDEF statements for debug or release.

As well I have deleted the Android folder that gets created when the project is run with no success, I have renamed my custom AndroidManifest.template.xml that I was using which forced delphi to create a new copy of the manifest and that did nothing.

I am out of ideas as to why my project would work in Debug but not Release.

Any help would be greatly appreciated.

Hello,

if you don't get meaningful tips here and you're on SA (subscription) it
might be a good time to use one of your free incidents.

Greetings

Markus
Steven Wiberg

Posts: 28
Registered: 3/6/12
Re: Project dies in Release configuration
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 30, 2015 11:26 AM   in response to: Markus Humm in response to: Markus Humm
Markus Humm wrote:

Hello,

if you don't get meaningful tips here and you're on SA (subscription) it
might be a good time to use one of your free incidents.

Greetings

Markus

I am on SA, how do we go about using these incidents we have?

Thanks
Steven Wiberg

Posts: 28
Registered: 3/6/12
Re: Project dies in Release configuration
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 30, 2015 11:54 AM   in response to: Markus Humm in response to: Markus Humm
Markus Humm wrote:

Hello,

if you don't get meaningful tips here and you're on SA (subscription) it
might be a good time to use one of your free incidents.

Greetings

Markus

So that will not be needed for the SA, I ended up finding the solution after making a blank project and comparing the different files in each of the projects after they were built.

Turns out that in my project that in the Deployment files there was an old classes.dex kicking around that was being deployed with my project (was pointing to C:\Program Files (x86)\Embarcadero\Studio\15.0\lib\android\release) along with the current one that is located in Android\Release\

I was able to uncheck the one that was located in the program files location, but not completely remove it from the project deployment options.

Once I did this it compiled and ran just fine.

No clue how this classes.dex got added to the deployment files, probably from some old version of the project that came from a previous version of Rad Studio.
Markus Humm

Posts: 5,113
Registered: 11/9/03
Re: Project dies in Release configuration
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 30, 2015 11:44 PM   in response to: Steven Wiberg in response to: Steven Wiberg
Am 30.09.2015 um 20:54 schrieb Steven Wiberg:
Markus Humm wrote:

Hello,

if you don't get meaningful tips here and you're on SA (subscription) it
might be a good time to use one of your free incidents.

Greetings

Markus

So that will not be needed for the SA, I ended up finding the solution after making a blank project and comparing the different files in each of the projects after they were built.

Turns out that in my project that in the Deployment files there was an old classes.dex kicking around that was being deployed with my project (was pointing to C:\Program Files (x86)\Embarcadero\Studio\15.0\lib\android\release) along with the current one that is located in Android\Release\

I was able to uncheck the one that was located in the program files location, but not completely remove it from the project deployment options.

Once I did this it compiled and ran just fine.

No clue how this classes.dex got added to the deployment files, probably from some old version of the project that came from a previous version of Rad Studio.

Great you found a solution. As for SA: there's some support portal
somewhere on EMBTs website where you'd need to log in and enter your case.

Greetings

Markus
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02