Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.


Welcome, Guest
Guest Settings
Help

Thread: Switching to clang -> IDE crashes


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 7 - Last Post: Dec 27, 2017 5:30 PM Last Post By: Keith Dopson
Herwig Huber

Posts: 5
Registered: 2/19/02
Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 30, 2017 12:59 AM
Hello World,

I am using C++ Builder XE10 Seattle Enterprise.

Because I wanted to use the parallel compiling and some C++11 features I switched my project over to use the clang compiler instead of the classic borland compiler.
After solving a couple of issues (e.g. Components that were compiled with the classic compiler) and after reinstalling the complete IDE I am still facing a lot of probems.

- Code completion is horrible slow - the IDE hangs on every second typed letter for a couple of seconds up to 2 minutes.
- The IDE crashes every 5 minutes.

I have absolutely no idea how to solve these problems: Are there any logs that will point me to the right direction?

Herwig
Oliver Weinheimer

Posts: 73
Registered: 8/20/04
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 30, 2017 3:04 AM   in response to: Herwig Huber in response to: Herwig Huber
Hi Herwig,

"Code completion" does not work.
You have to disable it - via Options -> Editor Options.
Also unchecked "Code parameters" and "Tooltip symbol insight" .
I am on RAD Tokyo coding for Win 64 - but these features did not work since at least ten years - not in Seattle, not in Berlin, not in Tokyo (I think they are slightly improved, but waiting 30 seconds is just as unacceptable as waiting 60 seconds).

As far as I can remember the stability of Seattle was Ok - so maybe you have also some other problems with your installation.

Best - Oliver
Herwig Huber

Posts: 5
Registered: 2/19/02
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 30, 2017 8:01 AM   in response to: Oliver Weinheimer in response to: Oliver Weinheimer
Thanks for your answer

As far as I can remember the stability of Seattle was Ok - so maybe you have also some other problems with your installation.

My Installation should be ok: I alredy re-installed cppbuilder.
Maybe there is something wrong with some 3rd party components I am using:
- TMS Component Pack
- SiComponents
Or maybe there is something wrong with my project settings or in the code itself.

The problem is: I have no idea where to start looking for, because the IDE crashes without any message...
Martin Stratmann

Posts: 18
Registered: 5/26/00
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 2, 2017 7:07 AM   in response to: Herwig Huber in response to: Herwig Huber
Am 30.03.2017 um 17:01 schrieb Herwig Huber:
Thanks for your answer

As far as I can remember the stability of Seattle was Ok - so maybe you have also some other problems with your installation.

My Installation should be ok: I alredy re-installed cppbuilder.
Maybe there is something wrong with some 3rd party components I am using:
- TMS Component Pack
- SiComponents
Or maybe there is something wrong with my project settings or in the code itself.

The problem is: I have no idea where to start looking for, because the IDE crashes without any message...
I've the same problem. IDE crashed every 5..10 Minutes. I guess, c++11
is unusable in RAD Studio

Martin
Herwig Huber

Posts: 5
Registered: 2/19/02
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 16, 2017 4:09 AM   in response to: Martin Stratmann in response to: Martin Stratmann
Martin Stratmann wrote:
Am 30.03.2017 um 17:01 schrieb Herwig Huber:
Thanks for your answer

As far as I can remember the stability of Seattle was Ok - so maybe you have also some other problems with your installation.

My Installation should be ok: I alredy re-installed cppbuilder.
Maybe there is something wrong with some 3rd party components I am using:
- TMS Component Pack
- SiComponents
Or maybe there is something wrong with my project settings or in the code itself.

The problem is: I have no idea where to start looking for, because the IDE crashes without any message...
I've the same problem. IDE crashed every 5..10 Minutes. I guess, c++11
is unusable in RAD Studio

Martin

I still have not been successful using C++ Builder Seattle with c++11.
I spent a lot of money (Enterprise Version) that does not work and nobody @Embarcadero is willing to fix these issues.
Is there any chance to get my money back?

Herwig
Keith Dopson

Posts: 63
Registered: 3/16/00
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 27, 2017 5:27 PM   in response to: Herwig Huber in response to: Herwig Huber
Herwig Huber wrote:
Martin Stratmann wrote:
snip
I still have not been successful using C++ Builder Seattle with c++11.
I spent a lot of money (Enterprise Version) that does not work and nobody @Embarcadero is willing to fix these issues.
Is there any chance to get my money back?

Herwig

Herwig, you are more likely to shove a stick of butter up a wildcat's rear with a red hot fireplace poker, than you are to get your money back.

Funny that you should pose that question.

After I purchased my bright, shiny Seattle 10, specifically to build a single x64 project for the 4th largest company in the U.S., and to be used by every single domestic and international tax account within that company, I found that x64 was so horribly broken that I ended up having to hand-disassemble and then remake numerous library pieces.

Bug reports produced NOTHING, ever. In desperation, my backup plan was to use Visual Studio 17, and it would have been a much-protracted process.

10.1 came with promise to correct 10 million bugs, but none of which affected my problems.

I was in weekly contact with the Austin sales girl, who apparently got wise to the trash being sold, and may have left for better company.

In any event, there was a constant push to "upgrade" to Tokyo, which I refused, pointing out that not a single problem I had reported had been corrected, much less properly addressed.

After the pushy sales chick left, her replacement had the gall to call me one day. He got his stupid head handed back to him, with an offer that I just come down to Austin and place it where the sun never shines, with a rejoinder to never call me again, and that Emb would NEVER receive another thin cent from me.

No, you will not receive a dime of your money back, and I don't care how sorry the product you received is found to perform. You'll be lucky to get your application built and out the door, without a bunch of fixes, most of which you will have to make, as you will get 0 (ZERO NULL) from quality.xxx

My numerous requests for refund were literally laughed at by sales. They simply pointed to the EULA, which clearly states that Emb is protected 100% from your gripe, and what you get is what you get.

My honest appraisal (based on 35+ years of programming history) is that you "might" get a functional XE?? something in the year 2525, if man is still alive.

Jaded about Emb? You bet.

I had extreme high regard and hope for XE, and was shafted from DAY 1 with the product.

For practically every C++ Windows application, I use Borland C++ Builder 5, which, for the most part, WORKS, x32.

VS for reliable x64, or XE 10.1 for VERY SIMPLE applications that have little 3rd party components, try/catch, etc.

For Android, I use Eclipse, for IOS, I use XCode on a Mac, and for embedded, I use whatever the manufacturer recommends.

10.1? ha it's a toy, an expensive experiment of failure. Check quality.emb, it is replete with fail

Edited by: Keith Dopson on Dec 27, 2017 5:27 PM
Brett Wilton

Posts: 45
Registered: 10/1/11
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 30, 2017 1:43 PM   in response to: Herwig Huber in response to: Herwig Huber
Some suggestions.

Turn off all code completion, that can make the IDE hang and is just plain terrible.

If your still getting crashes, remove all third party plugins. Test, if better start adding them back in to figure out which could be causing the issue.
Jan Dijkstra

Posts: 206
Registered: 11/4/99
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 17, 2017 7:30 AM   in response to: Brett Wilton in response to: Brett Wilton
Brett Wilton wrote:
Some suggestions.

Turn off all code completion, that can make the IDE hang and is just plain terrible.

If your still getting crashes, remove all third party plugins. Test, if better start adding them back in to figure out which could be causing the issue.

For me (still on XE8 Enterprise) the IDE instability was caused by Castalia. I had to go into the registry and remove the key that causes the IDE to load the Castalia BPL. Before I did that, I had access violations on virtually every single key stroke I typed in the editor. After I removed Castalia completely from the IDE, it has been rock solid.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02