Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: 64-bit and iOS 8 Requirements for New Apps



Permlink Replies: 2 - Last Post: May 6, 2015 7:43 PM Last Post By: Remy Lebeau (Te...
Elpis Informatica

Posts: 1
Registered: 11/1/14
64-bit and iOS 8 Requirements for New Apps
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 6, 2015 7:00 PM
Hello,

I'm using Delphi Xe6 and I'm trying to deploy my app, but it's shown the message below. Is there configuration or update that I can do to solve this issue?

Starting February 1, 2015, new iOS apps uploaded to the App Store must include 64-bit support and be built with the iOS 8 SDK, included in Xcode 6 or later. To enable 64-bit in your project, we recommend using the default Xcode build setting of “Standard architectures” to build a single binary with both 32-bit and 64-bit code.

Thanks!
Eli Mapstead

Posts: 5
Registered: 4/11/02
Re: 64-bit and iOS 8 Requirements for New Apps
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 6, 2015 7:31 PM   in response to: Elpis Informatica in response to: Elpis Informatica
Delphi XE8 added the IOS64 feature. XE6 does not have it.
Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: 64-bit and iOS 8 Requirements for New Apps
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 6, 2015 7:43 PM   in response to: Elpis Informatica in response to: Elpis Informatica
Elpis wrote:

Is there configuration or update that I can do to solve this issue?

Not for XE6, no. You need to upgrade to XE8 in order to produce iOS 64bit
apps.

--
Remy Lebeau (TeamB)
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02