Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: OSX app developed in FMX won't start from folder


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 2 - Last Post: May 19, 2015 9:07 AM Last Post By: Jim Duskes
Jim Duskes

Posts: 8
Registered: 6/15/15
OSX app developed in FMX won't start from folder  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 15, 2015 4:46 PM
I developed a cross-platform app which works well and starts fine from within Delphi. When I copy that app from the Platform Assistant folder to any other folder on my Mac, the icon shows a circle with a line through it and the app won't start. The app won't start even from the PA folder, but the icon shows okay in the PA folder.

I've been banging my head for most of the day on this. I'm using XE7. I've tried rebooting everything, checking permissions, etc. Any ideas?

Thanks

Edited by: Jim Duskes on May 15, 2015 4:46 PM

Edited by: Jim Duskes on May 15, 2015 4:52 PM
Mike Margerum

Posts: 590
Registered: 12/1/99
Re: OSX app developed in FMX won't start from folder [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 18, 2015 6:27 AM   in response to: Jim Duskes in response to: Jim Duskes
On 5/15/15 7:53 PM, Jim Duskes wrote:
I developed a cross-platform app which works well and starts fine from within Delphi. When I copy that app from the Platform Assistant folder to any other folder on my Mac, the icon shows a circle with a line through it and the app won't start. The app won't start even from the PA folder, but the icon shows okay in the PA folder.

I've been banging my head for most of the day on this. I'm using XE7. I've tried rebooting everything, checking permissions, etc. Any ideas?

Thanks

Edited by: Jim Duskes on May 15, 2015 4:46 PM

Edited by: Jim Duskes on May 15, 2015 4:52 PM

wild guess here but are you allowing non signed apps to run? in
settings / security & privacy theres an "Allow apps downloaded from"
option. You want to choose "Anywhere"
Jim Duskes

Posts: 8
Registered: 6/15/15
Re: OSX app developed in FMX won't start from folder [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 19, 2015 9:07 AM   in response to: Mike Margerum in response to: Mike Margerum
Thanks for the suggestion Mike! I was allowing non-signed apps. The problem turned out to be something with the app's icons in the icns file. I couldn't figure out exactly what, having spent so much time on this already. I simply started a new project and copied over the forms and code. It all worked fine after that.

Jim

Mike Margerum wrote:
On 5/15/15 7:53 PM, Jim Duskes wrote:
I developed a cross-platform app which works well and starts fine from within Delphi. When I copy that app from the Platform Assistant folder to any other folder on my Mac, the icon shows a circle with a line through it and the app won't start. The app won't start even from the PA folder, but the icon shows okay in the PA folder.

I've been banging my head for most of the day on this. I'm using XE7. I've tried rebooting everything, checking permissions, etc. Any ideas?

Thanks

Edited by: Jim Duskes on May 15, 2015 4:46 PM

Edited by: Jim Duskes on May 15, 2015 4:52 PM

wild guess here but are you allowing non signed apps to run? in
settings / security & privacy theres an "Allow apps downloaded from"
option. You want to choose "Anywhere"
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02