Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Fastreports 5/TeeChart2014 problem


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 14 - Last Post: Oct 6, 2015 11:47 PM Last Post By: Walter Schrabmair
Bill Zwirs

Posts: 20
Registered: 5/10/97
Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 8, 2014 4:38 PM
Delphi XE5
FastReports 5
TeeChart 2014 Pro

Have recently installed updates for Fastreports 5 (from version 4) and TeeChart2014 Pro (from TeeChart 2013 Pro). After the install process I used the FastReports Recompile Wizard and copied the .bpl files to the Windows/System32 folder......this is what I normally do without any problems. Now I get the following error message whenever I try to open any form that contains a Fastreport with a chart object in it:

Error creating form: Access violation at address 5046065C in module 'vcl190.bpl'. Read of address 00000000.

Although I get this message when trying to open the affected forms, I can perform a build on the project and it will compile and run without any problems.

I can duplicate the problem by simply dropping a fastreport component on a form, double click on that component to open it up and drop a chart object on the page. Close the form and the error will occur when I try to open that form up again.

If I uninstall TeeChart 2014 Pro and install TeeChart 2013 Pro, followed by the recompile procedure, the problem goes away.

Can someone please advise what the problem could be.

Thanks in advance

Bill
Yeray Alonso

Posts: 75
Registered: 6/12/11
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 10, 2014 4:33 AM   in response to: Bill Zwirs in response to: Bill Zwirs
Hello Bill,

Bill Zwirs wrote:
Delphi XE5
FastReports 5
TeeChart 2014 Pro

Have recently installed updates for Fastreports 5 (from version 4) and TeeChart2014 Pro (from TeeChart 2013 Pro). After the install process I used the FastReports Recompile Wizard and copied the .bpl files to the Windows/System32 folder......this is what I normally do without any problems. Now I get the following error message whenever I try to open any form that contains a Fastreport with a chart object in it:

Error creating form: Access violation at address 5046065C in module 'vcl190.bpl'. Read of address 00000000.

Although I get this message when trying to open the affected forms, I can perform a build on the project and it will compile and run without any problems.

I can duplicate the problem by simply dropping a fastreport component on a form, double click on that component to open it up and drop a chart object on the page. Close the form and the error will occur when I try to open that form up again.

If I uninstall TeeChart 2014 Pro and install TeeChart 2013 Pro, followed by the recompile procedure, the problem goes away.

Can someone please advise what the problem could be.

Does TeeChart Pro v2014 work fine without Fast-Reports for you?
If so, it will probably some problem in the integration of TeeChart into Fast-Reports. Then, you could try to contact Fast-Report directly since they are who support the integration of TeeChart into their components.

--
Best Regards

Yeray Alonso
Steema Support Central
Follow us in Twitter and Facebook

"Important note: If you are a TeeChart registered customer,
please post your support questions at Steema's Support
monitored Forums for a prompter reply."
http://support.steema.com
Bill Zwirs

Posts: 20
Registered: 5/10/97
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 10, 2014 4:17 PM   in response to: Yeray Alonso in response to: Yeray Alonso
Yes TeeChart does work fine without FastReports, so as you say, it appears to be a FastReports problem. I was under the impression that the FastReports people monitor this forum so would expect something from them but to play it safe I suppose I should also put an entry in their forum.

regards

Bill
Michael Philipp...

Posts: 41
Registered: 10/10/08
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 20, 2014 11:27 PM   in response to: Bill Zwirs in response to: Bill Zwirs
Hello,

You don't need to copy any files if you're using recompile wizard.
Also if you tried to compile FR4 or FR5 packages before, then some files
also appear in "Public\Documents\RAD Studio\12.0\Bpl" and
"Public\Documents\RAD Studio\12.0\Dcp".
And this valid for all FR packages. We usually recomend full clean from
FR libs for users who recompiles packages, because installer do not
remove some files if you did recompilation.

Steps you need to do:
1. Close IDE;
2. Remove all
dclfsTee19.Bpl/dclfsTee19.Dcp/fsTee19.Bpl/fsTee19.Dcp/dclfrxTee19.Bpl/dclfrxTee19.Dcp/frxTee19.Bpl/frxTee19.Dcp

at Windows/System32(Windows/SysWOW64 for x64 system),
"Public\Documents\RAD Studio\12.0\Bpl" and "Public\Documents\RAD
Studio\12.0\Dcp".
3. Run recompile wizard with administrative rights.
4. Select proper version of TeeChart/Compiler, chose correct path to
TeeChart libraries and compile.
5. Close Recompile wizard and run IDE.
6. Go to Install Packages and chose compiled dclfrxTee19.bpl.

09.04.2014 3:38, Bill Zwirs wrote:
Delphi XE5
FastReports 5
TeeChart 2014 Pro

Have recently installed updates for Fastreports 5 (from version 4) and TeeChart2014 Pro (from TeeChart 2013 Pro). After the install process I used the FastReports Recompile Wizard and copied the .bpl files to the Windows/System32 folder......this is what I normally do without any problems. Now I get the following error message whenever I try to open any form that contains a Fastreport with a chart object in it:

Error creating form: Access violation at address 5046065C in module 'vcl190.bpl'. Read of address 00000000.

Although I get this message when trying to open the affected forms, I can perform a build on the project and it will compile and run without any problems.

I can duplicate the problem by simply dropping a fastreport component on a form, double click on that component to open it up and drop a chart object on the page. Close the form and the error will occur when I try to open that form up again.

If I uninstall TeeChart 2014 Pro and install TeeChart 2013 Pro, followed by the recompile procedure, the problem goes away.

Can someone please advise what the problem could be.

Thanks in advance

Bill

--
Best regards,
Michael Philippenko mailto:michael@fast-report.com
Fast Reports - reporting must be Fast!!
http://www.fast-report.com
Bill Zwirs

Posts: 20
Registered: 5/10/97
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 29, 2014 4:56 PM   in response to: Michael Philipp... in response to: Michael Philipp...
You don't need to copy any files if you're using recompile wizard.
Also if you tried to compile FR4 or FR5 packages before, then some files
also appear in "Public\Documents\RAD Studio\12.0\Bpl" and
"Public\Documents\RAD Studio\12.0\Dcp".
And this valid for all FR packages. We usually recomend full clean from
FR libs for users who recompiles packages, because installer do not
remove some files if you did recompilation.

Steps you need to do:
1. Close IDE;
2. Remove all
dclfsTee19.Bpl/dclfsTee19.Dcp/fsTee19.Bpl/fsTee19.Dcp/dclfrxTee19.Bpl/dclfrxTee19.Dcp/frxTee19.Bpl/frxTee19.Dcp

at Windows/System32(Windows/SysWOW64 for x64 system),
"Public\Documents\RAD Studio\12.0\Bpl" and "Public\Documents\RAD
Studio\12.0\Dcp".
3. Run recompile wizard with administrative rights.
4. Select proper version of TeeChart/Compiler, chose correct path to
TeeChart libraries and compile.
5. Close Recompile wizard and run IDE.
6. Go to Install Packages and chose compiled dclfrxTee19.bpl.

Michael,

Tried what you suggested but made no difference. Think I'll just wait for the Fastreports (and TeeChart) update for XE6 and see if that works.

Any idea how long it will be before those updates are released???

regards

Bill
Yeray Alonso

Posts: 75
Registered: 6/12/11
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 30, 2014 12:19 AM   in response to: Bill Zwirs in response to: Bill Zwirs
Hi Bill,

Bill Zwirs wrote:
Think I'll just wait for the Fastreports (and TeeChart) update for XE6 and see if that works.

Any idea how long it will be before those updates are released???

We've released a beta version for source code customers supporting XE6 and hope to finish a stable release soon, but I'm afraid I can't tell you when it will be published.
--
Best Regards

Yeray Alonso
Steema Support Central
Follow us in Twitter and Facebook

"Important note: If you are a TeeChart registered customer,
please post your support questions at Steema's Support
monitored Forums for a prompter reply."
http://support.steema.com
Bill Zwirs

Posts: 20
Registered: 5/10/97
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 11, 2014 8:44 PM   in response to: Yeray Alonso in response to: Yeray Alonso

We've released a beta version for source code customers supporting XE6 and hope to finish a stable release soon, but I'm afraid I can't tell you when it will be published.
--

I don't have access to the beta version. Any details yet on a possible release date for the stable version???

regards

Bill
Narcis Calvet

Posts: 3
Registered: 6/10/05
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 12, 2014 12:06 AM   in response to: Bill Zwirs in response to: Bill Zwirs
Hello Bill,

Bill Zwirs wrote:

I don't have access to the beta version. Any details yet on a possible release date for the stable version???

The beta version is only available to source code customers. We expect to publish the stable version this week.

Best regards,
Narcís Calvet

Steema Software
www.steema.com
Michael Philipp...

Posts: 41
Registered: 10/10/08
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 30, 2014 6:19 AM   in response to: Bill Zwirs in response to: Bill Zwirs
Dear Bill,

Builds for XE6 will be available today in Customer Panel.

30.04.2014 3:56, Bill Zwirs wrote:
You don't need to copy any files if you're using recompile wizard.
Also if you tried to compile FR4 or FR5 packages before, then some files
also appear in "Public\Documents\RAD Studio\12.0\Bpl" and
"Public\Documents\RAD Studio\12.0\Dcp".
And this valid for all FR packages. We usually recomend full clean from
FR libs for users who recompiles packages, because installer do not
remove some files if you did recompilation.

Steps you need to do:
1. Close IDE;
2. Remove all
dclfsTee19.Bpl/dclfsTee19.Dcp/fsTee19.Bpl/fsTee19.Dcp/dclfrxTee19.Bpl/dclfrxTee19.Dcp/frxTee19.Bpl/frxTee19.Dcp

at Windows/System32(Windows/SysWOW64 for x64 system),
"Public\Documents\RAD Studio\12.0\Bpl" and "Public\Documents\RAD
Studio\12.0\Dcp".
3. Run recompile wizard with administrative rights.
4. Select proper version of TeeChart/Compiler, chose correct path to
TeeChart libraries and compile.
5. Close Recompile wizard and run IDE.
6. Go to Install Packages and chose compiled dclfrxTee19.bpl.

Michael,

Tried what you suggested but made no difference. Think I'll just wait for the Fastreports (and TeeChart) update for XE6 and see if that works.

Any idea how long it will be before those updates are released???

regards

Bill

--
Best regards,
Michael Philippenko mailto:michael@fast-report.com
Fast Reports - reporting must be Fast!!
http://www.fast-report.com
Bill Zwirs

Posts: 20
Registered: 5/10/97
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 1, 2014 3:32 PM   in response to: Michael Philipp... in response to: Michael Philipp...
Michael Philippenko wrote:
Dear Bill,

Builds for XE6 will be available today in Customer Panel.

I see there is a build available for VCL4.....but nothing for VCL5.

Bill

Half a day later.........it's there now. Thanks.

Edited by: Bill Zwirs on May 1, 2014 9:56 PM

Bill Zwirs

Posts: 20
Registered: 5/10/97
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 21, 2014 5:43 PM   in response to: Michael Philipp... in response to: Michael Philipp...
Still having the same problem. Have now installed XE6 on brand new machine along with fastreports 5 and teechart 2014 Pro. I have now had this same problem on 3 different machines!

Has anyone else got the same problem? Have also raised ticket with FastReports but not getting any info from there. A simple confirmation that there is a problem and is being worked on would be nice.

Easy to duplicate (on my machine anyway)

1. Create new project
2. Place fastreport report component and chart object on a form.
3. Double click on fastreport object to open report and place a report chart object from the left hand column of the report page onto the page.
4. Close form
5. Save and close project
6. Open project

Get the following error message:

Error creating form: Access violation at address 504F06A4 in module 'vcl200.bpl'. read of address 00000000.

The code page is displayed in the IDE but no design page.

So, can someone please confirm if there is an actual error with fastreports or am I totally missing something. This is really frustrating me and stopping me from moving my projects to XE6. In XE5 I have moved back to TeeChart 2013 Pro which doesn't have this problem. I would do the same for XE6 but there isn't a TeeChart 2013 Pro version for XE6.

Bill
Narcis Calvet

Posts: 3
Registered: 6/10/05
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 3, 2014 1:21 AM   in response to: Bill Zwirs in response to: Bill Zwirs
Hi Bill,

Bill Zwirs wrote:

In XE5 I have moved back to TeeChart 2013 Pro which doesn't have this problem. I would do the same for XE6 but there isn't a TeeChart 2013 Pro version for XE6.

There's a TeeChart Pro 2014 release for XE6, more info here: http://www.teechart.net/support/viewtopic.php?f=3&t=14911

Best regards,

Narcís Calvet
Steema Software
Bill Zwirs

Posts: 20
Registered: 5/10/97
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 3, 2014 9:34 PM   in response to: Narcis Calvet in response to: Narcis Calvet
Narcis Calvet wrote:
Hi Bill,

Bill Zwirs wrote:

In XE5 I have moved back to TeeChart 2013 Pro which doesn't have this problem. I would do the same for XE6 but there isn't a TeeChart 2013 Pro version for XE6.

There's a TeeChart Pro 2014 release for XE6, more info here: http://www.teechart.net/support/viewtopic.php?f=3&t=14911

Best regards,

Narcís Calvet
Steema Software

Narcis,

This problem exists on both XE5 and XE6 with Fastreports 5 VCL and TeeChart 2014 Pro. The problem is when Fastreprt property StoreInDFM is set to true and a chart object is placed in the report. In this case the form will no longer display in the IDE (when re-opening the form in the IDE) so unable to work on it.....although will still compile without any problems. The only way around it is to set StoreInDFM to false and safe report as .fr3 file, but need to do this part in XE5 with TeeChart 2013 Pro. Have logged this problem as a ticket at Fastreports and on their forum but just silence at this stage.

Would really appreciate an answer/advice.

regards

Bill
Walter Schrabmair

Posts: 2
Registered: 12/27/01
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 6, 2015 1:07 PM   in response to: Bill Zwirs in response to: Bill Zwirs

This problem exists on both XE5 and XE6 with Fastreports 5 VCL and TeeChart 2014 Pro. The problem is when Fastreprt property StoreInDFM is set to true and a chart object is placed in the report. In this case the form will no longer display in the IDE (when re-opening the form in the IDE) so unable to work on it.....although will still compile without any problems. The only way around it is to set StoreInDFM to false and safe report as .fr3 file, but need to do this part in XE5 with TeeChart 2013 Pro. Have logged this problem as a ticket at Fastreports and on their forum but just silence at this stage.

Would really appreciate an answer/advice.

regards

Bill

Dear Bill,
I have Delphi XE6 and Teechart 2015 and Fastreport 4. Even when I unset the StoreInDFM I still have the "Access violation".
What could I do? In Delphi 7 with Teechart 707 the Module works find. But I want tu run it in XE6!
Please help.
thanks
Walter
Walter Schrabmair

Posts: 2
Registered: 12/27/01
Re: Fastreports 5/TeeChart2014 problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 6, 2015 11:47 PM   in response to: Walter Schrabmair in response to: Walter Schrabmair
Dear Bill,
I have Delphi XE6 and Teechart 2015 and Fastreport 4. Even when I unset the StoreInDFM I still have the "Access violation".
What could I do? In Delphi 7 with Teechart 707 the Module works find. But I want tu run it in XE6!
Please help.
thanks
Walter

Dear Bill,
I found the bug. It was another Class, which could not be found. I think the mentioned Problem is already solved with XE6 and Teechart 2015
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02