Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: OpenGL greater than 2.0 in C++ Builder VCL



Permlink Replies: 1 - Last Post: Sep 28, 2016 11:09 PM Last Post By: Larry Johnson
James Williams

Posts: 63
Registered: 8/22/13
OpenGL greater than 2.0 in C++ Builder VCL
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 11, 2016 4:23 AM
Has anyone tried to use OpenGL version that is greater than version 2.0, for which is supplied with C++ Builder VCL? I would like to use version 4, but I am not certain what headaches might come along in order to support it.

Thanks,

James
Larry Johnson

Posts: 86
Registered: 6/7/14
Re: OpenGL greater than 2.0 in C++ Builder VCL
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 28, 2016 11:09 PM   in response to: James Williams in response to: James Williams
I have used OpenGL 2.0 and 3.1 in C++Builder. I believe anything before v3.3 is obsolete because OpenGL 3.3 is where the Shading Language(SL) were introduced. The code in C++Builder for using OpenGL 4+ with shading is very different from pre-shading versions of OpenGL. I would recommend finding a OpenGL 2.0 sample application that performs tasks you want and then outsourcing a conversion to OpenGL 4. I believe the web site Upwork at https://www.upwork.com/ has freelancers that are familiar with Delphi/C++Builder. It is my understanding Embarcadero wants to focus on FireMonkey 3D rather than OpenGL or Direct2D/3D so you might have trouble finding OpenGL help here on the forums.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02