Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: New Windows Update and TButton->Caption



Permlink Replies: 4 - Last Post: Jun 19, 2017 3:55 PM Last Post By: Earl Staley
Earl Staley

Posts: 99
Registered: 4/9/07
New Windows Update and TButton->Caption
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 16, 2017 6:18 PM
Windows 10 did a very large update on my computer today. After the update, I cannot use the Object Inspector in C++ Professional Berlin 10.1 to add a caption to a button correctly. For example, I tried to add the caption "Auto Run" to a button. The caption will only take one letter, with the next letter replacing the first letter. If I type 'A' the caption shows the 'A'. When I try to add 'u' the 'A' disappears and is replaced by the 'u'.

The editor is in 'insert' mode.

I can however, add a caption correctly in Tokyo 10.2.

I have re-booted the computer and Berlin 10.1, but the problem remains.

I have never seen this problem prior to the Windows update.

The new Windows 10 Home info is:
Version 1703
OS Build 15063.413

Anyone else having this problem?

Earl
Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: New Windows Update and TButton->Caption
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 16, 2017 6:40 PM   in response to: Earl Staley in response to: Earl Staley
Earl Staley wrote:

Windows 10 did a very large update on my computer today. After the
update, I cannot use the Object Inspector in C++ Professional Berlin
10.1 to add a caption to a button correctly.

Have you filed a bug report with Embarcadero?

For example, I tried to add the caption "Auto Run" to a button. The
caption will only take one letter, with the next letter replacing the
first letter. If I type 'A' the caption shows the 'A'. When I try to
add 'u' the 'A' disappears and is replaced by the 'u'.

What you describe makes no sense. You are typing into a normal text
control. It should be accepting the full string as you type it, and
applying the full string to the property after each characters. That
is how it has always worked.

The TButton.Caption property is actually the inherited TControl.Caption
property promoted to published. Are you having the same problem with
all components that expose the TControl.Caption property? Or only
TButton specifically?

The editor is in 'insert' mode.

What do you mean? When is it not in 'insert' mode?

I can however, add a caption correctly in Tokyo 10.2.

What about setting the Caption property in code at runtime?

Button1.Caption := 'Auto Run';


--
Remy Lebeau (TeamB)
Earl Staley

Posts: 99
Registered: 4/9/07
Re: New Windows Update and TButton->Caption
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 16, 2017 9:54 PM   in response to: Remy Lebeau (Te... in response to: Remy Lebeau (Te...
Have you filed a bug report with Embarcadero?

No, the problem showed up coincidentally with the Windows 10 upgrade, so I suspect the problem is with the upgrade.

What you describe makes no sense. You are typing into a normal text
control. It should be accepting the full string as you type it, and
applying the full string to the property after each characters. That
is how it has always worked.

That is how it has always worked for me also.

The TButton.Caption property is actually the inherited TControl.Caption
property promoted to published. Are you having the same problem with
all components that expose the TControl.Caption property? Or only
TButton specifically?

I am not at the computer that has Berlin 10.1 installed. I will check other controls tomorrow.

What do you mean? When is it not in 'insert' mode?

I believe the Insert key toggles the editor between the 'Insert' and 'Overwrite' modes.

What about setting the Caption property in code at runtime?

That is how I had to set the caption, since I could not do it in the Object Inspector.

Remy Lebeau (TeamB)
Rudy Velthuis (...


Posts: 7,731
Registered: 9/22/99
Re: New Windows Update and TButton->Caption
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 17, 2017 1:20 AM   in response to: Earl Staley in response to: Earl Staley
Earl Staley wrote:

Have you filed a bug report with Embarcadero?

No, the problem showed up coincidentally with the Windows 10 upgrade,
so I suspect the problem is with the upgrade.

And yet it should be reported, so they can make 10.1 Berlin work
properly again, on that latest Win10.

--
Rudy Velthuis http://www.rvelthuis.de

"I was under medication when I made the decision to burn the
tapes."
-- Richard Nixon
Earl Staley

Posts: 99
Registered: 4/9/07
Re: New Windows Update and TButton->Caption
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 19, 2017 3:55 PM   in response to: Earl Staley in response to: Earl Staley
After examining other C++ Berlin 10.1 projects, the problem with the Caption only happens on that one project. It does not appear on the other projects nor on a new VCL project. I can add captions to labels but I cannot add captions using the Object Inspector on any of the buttons in that project.

I do not understand how any code in the project (which worked fine before the windows 10 upgrade) could possibly effect anything I do in the editor, prior to compiling and linking the project, but it did.

I am just chalking this up to one of the great mysteries of modern computers and moving on.

Earl
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02