Watch, Follow, &
Connect with Us

Welcome, Guest
Guest Settings
Help

Thread: 10.2.1 link error



Permlink Replies: 4 - Last Post: Sep 13, 2017 12:16 AM Last Post By: Robin Pellatt Threads: [ Previous | Next ]
Robin Pellatt

Posts: 21
Registered: 10/2/11
10.2.1 link error
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 8, 2017 2:20 AM
We've just upgraded from Tokyo 10.2 to 10.2.1. Now one of our projects won't link when built from the IDE. Any way to resolve this? It works fine when building from the command line.

[ilink32 Warning] Warning: BSS : 0x00000000 / 0x01000000
[ilink32 Warning] Warning: CODE : 0x001227a5 / 0x01000000
[ilink32 Warning] Warning: DATA : 0x00041984 / 0x01000000
[ilink32 Warning] Warning: DEBNAM : 0x0027cab0 / 0x01000000
[ilink32 Warning] Warning: DEBSYM : 0x0027316f / 0x01000000
[ilink32 Warning] Warning: DEBTYP : 0x00317eba / 0x01000000
[ilink32 Warning] Warning: EXIT : 0x00000096 / 0x01000000
[ilink32 Warning] Warning: Extdef flags : 0x00000782 / 0x00004000
[ilink32 Warning] Warning: Extdefs : 0x00001e08 / 0x00004000
[ilink32 Warning] Warning: External types : 0x00003368 / 0x00040000
[ilink32 Warning] Warning: INIT : 0x00000096 / 0x01000000
[ilink32 Warning] Warning: Import symbols : 0x00007bb4 / 0x00100000
[ilink32 Warning] Warning: Line number cache : 0x000520b0 / 0x00060000
[ilink32 Warning] Warning: OBJ symbols : 0x000d2080 / 0x00400000
[ilink32 Warning] Warning: Public GSX : 0x0000fd7c / 0x000c0000
[ilink32 Warning] Warning: Public types : 0x0001b6f8 / 0x00080000
[ilink32 Warning] Warning: Publics : 0x0008e95c / 0x000c0000
[ilink32 Warning] Warning: SegRelocs : 0x001309d4 / 0x00800000
[ilink32 Warning] Warning: StringBlock : 0x0004974d / 0x01000000
[ilink32 Warning] Warning: TLS : 0x0000009c / 0x01000000
[ilink32 Warning] Warning: Type names : 0x00048af5 / 0x00100000
[ilink32 Warning] Warning: Virdefs : 0x0000fd7c / 0x00020000
[ilink32 Warning] Warning: D:/WORK/Projects/SeisPos/Bin/Debug/SeisPos.ilc: 0x01c28000 / 0x08000000
[ilink32 Warning] Warning: D:/WORK/Projects/SeisPos/Bin/Debug/SeisPos.ild: 0x004d2000 / 0x08000000
[ilink32 Error] "ilink32" exited with code -1073741819.
Failed
Oliver Weinheimer

Posts: 72
Registered: 8/20/04
Re: 10.2.1 link error
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 8, 2017 6:47 AM   in response to: Robin Pellatt in response to: Robin Pellatt
Robin Pellatt

Posts: 21
Registered: 10/2/11
Re: 10.2.1 link error
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 12, 2017 4:29 AM   in response to: Oliver Weinheimer in response to: Oliver Weinheimer
Oliver Weinheimer wrote:
Maybe this thread helps:

https://plus.google.com/u/0/117762426461479337959/posts/3E6HLhL9QDg

Thanks, have done more digging and it does now look like the "delay load DLL" is the cause. Doesn't seem to be any progress on the issue yet though: https://quality.embarcadero.com/browse/RSP-18765.
Oliver Weinheimer

Posts: 72
Registered: 8/20/04
Re: 10.2.1 link error
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 12, 2017 4:40 AM   in response to: Robin Pellatt in response to: Robin Pellatt
Do you have a delay loaded library?
If yes - maybe you can load the library directly.
That was the workaround for me.

I think/hope Embarcadero is working on a hotfix for the "delay-loaded-library" problem
Robin Pellatt

Posts: 21
Registered: 10/2/11
Re: 10.2.1 link error
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 13, 2017 12:16 AM   in response to: Oliver Weinheimer in response to: Oliver Weinheimer
Oliver Weinheimer wrote:
Do you have a delay loaded library?
If yes - maybe you can load the library directly.
That was the workaround for me.

I think/hope Embarcadero is working on a hotfix for the "delay-loaded-library" problem

Thanks, we do have a DLL, but I've now rolled back to 10.2 and will wait for the next update.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02