Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.

Welcome, Guest
Guest Settings

Thread: Issue passing tguid from client app to datasnap rest server

This question is not answered. Helpful answers available: 2. Correct answers available: 1.

Permlink Replies: 0
J Kelly Wilkerson

Posts: 2
Registered: 9/1/01
Issue passing tguid from client app to datasnap rest server  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 20, 2017 1:32 PM
I have an existing database that uses GUIDs for keys. I have a DataSnap REST Server with queries that I have tested and return data using the Query Editor. I have the parameters set as Input and ftGUID for the key fields. When I create the Getx methods using a parameter of type TGUID, the methods don't get exposed in the Client Classes. When I create those methods to accept the key parameters as string, the Client Classes get generated and I can use them just fine. However, when I pass a string that represents the GUID to the REST method and attempt the convert the string to a GUID using StringToGUID to pass to the query, I receive an error stating that the GUID is invalid. I've tried everything I can think of to get this going, but no luck. I've tried to execute the REST method from the browser passing in the GUID as a string in the following formats: {4F2EF09E-83F7-47BD-8EAE-BBCCFF569463}, 4F2EF09E-83F7-47BD-8EAE-BBCCFF569463, '{4F2EF09E-83F7-47BD-8EAE-BBCCFF569463}', '4F2EF09E-83F7-47BD-8EAE-BBCCFF569463'. The first option just takes me back to the login screen and doesn't even attempt to give me a result. All of the other three formats return the GUID Invalid error.

Any input or help with this is greatly appreciated.

Thanks in advance.

Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02