Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Licensing Problems with IBToGo - Installation Chaos Delphi 10.2


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 2 - Last Post: Dec 8, 2017 10:22 AM Last Post By: Sriram Balasubr... Threads: [ Previous | Next ]
Wolfgang Weber

Posts: 1
Registered: 3/9/05
Licensing Problems with IBToGo - Installation Chaos Delphi 10.2  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 16, 2017 2:07 AM
first of all, the new delphi version (10.2 Tokyo) is the most complicated i've ever used so far. Skip this paragraph and jump to the actual problem if you dont want to read my moaning. We received a link to an installation-dvd-image, about 6 gigabyte, downloaded it, burnt it, installed it. well, it won't work this way. we couldn't get the license to work with this installation. so, uninstalled, tried the webinstaller, now it worked. this took hours of course. then, the android sdk installed by delphi did not work at all. After many different tries to get it to work, we decided to install our own android sdk manually, changed the path-settings in delphi, now it works. again, this took hours. so, now i took my first steps with a few small android apps. well, the ide has some annoying bugs and needs to be restarted about every 2 or 3 hours to get rid of error-messages. another annoying thing is the live-bindings-editor. if you delete one link, it happens very often, that all links disappear.

the actual problem:
now i wanted to have this app running on my android phone, android api19:
http://docwiki.embarcadero.com/RADStudio/Tokyo/de/Mobile-Tutorial:_Verwenden_von_InterBase_ToGo_mit_FireDac_(iOS_und_Android)
or in english it should be this
http://docwiki.embarcadero.com/RADStudio/Tokyo/en/Mobile_Tutorial:_Using_InterBase_ToGo_with_FireDAC_(iOS_and_Android)

there is no chance to get this running. i worked through all tutorials (embarcadero-wiki, -videos) concerning IBToGo licensing, installing, etc.. There was nothing to solve my problem. Of course i had again to do it all manually. From the system variable IBREDISTDIR to the installation of files and registering. but now, its all in the right place and still doesn't work. by the way, there are many broken links in the tutorials. you simply get to the main page, if you hit one of those links.

if i try to use IBToGo on my android phone, i simply get the message "not licensed".

IBREDISTDIR is set to "C:\Users\Public\Documents\Embarcadero\InterBase\redist\InterBaseXE7".
In this folder i placed the registration file, renamed to "reg_ibtogo.txt".
In my project i went to the deployment-screen and added the IBToGo Driver. Its definitely set up correctly. All files are in the correct place.

Even though i disabled the IBLite driver, the error message i get is
'[FireDAC][Phys][IBLite]product INTERBASE is not licensed'

I of course also tried it with the IBLite CheckBox checked and IBToGo not checked, and with both checked also.
It's always the same error '[FireDAC][Phys][IBLite]product INTERBASE is not licensed'.

Any help is appreciated.
Sorry for my anger. ;)
Sriram Balasubr...

Posts: 132
Registered: 10/19/99
Re: Licensing Problems with IBToGo - Installation Chaos Delphi 10.2  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 29, 2017 11:43 AM   in response to: Wolfgang Weber in response to: Wolfgang Weber
Are you the same user communicating in this post at https://community.embarcadero.com/forum/installation-issues/8306-interbase-togo-installing-licensing#12320

Hope the conversation out there helps you resolve the problem.

Wolle Weber wrote:
first of all, the new delphi version (10.2 Tokyo) is the most complicated i've ever used so far. Skip this paragraph and jump to the actual problem if you dont want to read my moaning. We received a link to an installation-dvd-image, about 6 gigabyte, downloaded it, burnt it, installed it. well, it won't work this way. we couldn't get the license to work with this installation. so, uninstalled, tried the webinstaller, now it worked. this took hours of course. then, the android sdk installed by delphi did not work at all. After many different tries to get it to work, we decided to install our own android sdk manually, changed the path-settings in delphi, now it works. again, this took hours. so, now i took my first steps with a few small android apps. well, the ide has some annoying bugs and needs to be restarted about every 2 or 3 hours to get rid of error-messages. another annoying thing is the live-bindings-editor. if you delete one link, it happens very often, that all links disappear.

the actual problem:
now i wanted to have this app running on my android phone, android api19:
http://docwiki.embarcadero.com/RADStudio/Tokyo/de/Mobile-Tutorial:_Verwenden_von_InterBase_ToGo_mit_FireDac_(iOS_und_Android)
or in english it should be this
http://docwiki.embarcadero.com/RADStudio/Tokyo/en/Mobile_Tutorial:_Using_InterBase_ToGo_with_FireDAC_(iOS_and_Android)

there is no chance to get this running. i worked through all tutorials (embarcadero-wiki, -videos) concerning IBToGo licensing, installing, etc.. There was nothing to solve my problem. Of course i had again to do it all manually. From the system variable IBREDISTDIR to the installation of files and registering. but now, its all in the right place and still doesn't work. by the way, there are many broken links in the tutorials. you simply get to the main page, if you hit one of those links.

if i try to use IBToGo on my android phone, i simply get the message "not licensed".

IBREDISTDIR is set to "C:\Users\Public\Documents\Embarcadero\InterBase\redist\InterBaseXE7".
In this folder i placed the registration file, renamed to "reg_ibtogo.txt".
In my project i went to the deployment-screen and added the IBToGo Driver. Its definitely set up correctly. All files are in the correct place.

Even though i disabled the IBLite driver, the error message i get is
'[FireDAC][Phys][IBLite]product INTERBASE is not licensed'

I of course also tried it with the IBLite CheckBox checked and IBToGo not checked, and with both checked also.
It's always the same error '[FireDAC][Phys][IBLite]product INTERBASE is not licensed'.

Any help is appreciated.
Sorry for my anger. ;)
Sriram Balasubr...

Posts: 132
Registered: 10/19/99
Re: Licensing Problems with IBToGo - Installation Chaos Delphi 10.2  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 8, 2017 10:22 AM   in response to: Sriram Balasubr... in response to: Sriram Balasubr...
Wolle,

I understand you got some help from our Support engineer to resolve this issue. Here are some comments for others who may have a similar issue working with IBToGo 2017 on Mobile (iOS/Android) from RAD Tokyo.

If you are a customer downloading InterBase 2017 IBToGo kit from GetIt repository for RAD Studio, you will need to execute a couple of manual steps to make IBToGo 2017 work for Mobile platform deployment. Since IBToGo 2017 is not automatically installed by RAD Tokyo (yet), these steps are necessary to be done manually.

In the downloaded image for IBToGo 2017 zip file...
- Extract libibtogo.a from ios_device.zip to both the lib\iosDevice32\debug and the lib\iosDevice32\release folders within your RAD Studio install.
- Extract libibtogo.a from ios64_device.zip to both the lib\iosDevice64\debug and the lib\iosDevice64\release folders within your RAD Studio install.
- Extract libibtogo.a from android_togo.zip to both the lib\android\debug and the lib\android\release folders within your RAD Studio install.
- rebuild and deploy your app to iOS/Android device.

Best wishes,
Sriram

Sriram Balasubramanian wrote:
Are you the same user communicating in this post at https://community.embarcadero.com/forum/installation-issues/8306-interbase-togo-installing-licensing#12320

Hope the conversation out there helps you resolve the problem.

Wolle Weber wrote:
first of all, the new delphi version (10.2 Tokyo) is the most complicated i've ever used so far. Skip this paragraph and jump to the actual problem if you dont want to read my moaning. We received a link to an installation-dvd-image, about 6 gigabyte, downloaded it, burnt it, installed it. well, it won't work this way. we couldn't get the license to work with this installation. so, uninstalled, tried the webinstaller, now it worked. this took hours of course. then, the android sdk installed by delphi did not work at all. After many different tries to get it to work, we decided to install our own android sdk manually, changed the path-settings in delphi, now it works. again, this took hours. so, now i took my first steps with a few small android apps. well, the ide has some annoying bugs and needs to be restarted about every 2 or 3 hours to get rid of error-messages. another annoying thing is the live-bindings-editor. if you delete one link, it happens very often, that all links disappear.

the actual problem:
now i wanted to have this app running on my android phone, android api19:
http://docwiki.embarcadero.com/RADStudio/Tokyo/de/Mobile-Tutorial:_Verwenden_von_InterBase_ToGo_mit_FireDac_(iOS_und_Android)
or in english it should be this
http://docwiki.embarcadero.com/RADStudio/Tokyo/en/Mobile_Tutorial:_Using_InterBase_ToGo_with_FireDAC_(iOS_and_Android)

there is no chance to get this running. i worked through all tutorials (embarcadero-wiki, -videos) concerning IBToGo licensing, installing, etc.. There was nothing to solve my problem. Of course i had again to do it all manually. From the system variable IBREDISTDIR to the installation of files and registering. but now, its all in the right place and still doesn't work. by the way, there are many broken links in the tutorials. you simply get to the main page, if you hit one of those links.

if i try to use IBToGo on my android phone, i simply get the message "not licensed".

IBREDISTDIR is set to "C:\Users\Public\Documents\Embarcadero\InterBase\redist\InterBaseXE7".
In this folder i placed the registration file, renamed to "reg_ibtogo.txt".
In my project i went to the deployment-screen and added the IBToGo Driver. Its definitely set up correctly. All files are in the correct place.

Even though i disabled the IBLite driver, the error message i get is
'[FireDAC][Phys][IBLite]product INTERBASE is not licensed'

I of course also tried it with the IBLite CheckBox checked and IBToGo not checked, and with both checked also.
It's always the same error '[FireDAC][Phys][IBLite]product INTERBASE is not licensed'.

Any help is appreciated.
Sorry for my anger. ;)
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02